Follow

LIMS-plus v3.8 Suite System Requirements Guide

Attached is the LIMS-plus v3.8 System Requirements Guide.  Feel free to download for review and reference.  Please contact JusticeTrax Support for any questions or comments.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk